Android f-droid sending but not receiving


I’m trying to send messages between Jami on Android installed from F-droid (version 20220924-01) and Jami on iOS (version 3.07 20211218, Taranis on iOS 15.0.2).

On Android messages are received from the iOS device but messages sent from Android are not received on the iOS device.

Messages sent to and from the iOS device to another iOS device are received ok.

I can makes calls between the Android and iOS devices.

I’ve tried toggling off and on the proxy servers etc on Android but it doesn’t seem to help.

The android version of Jami is a little bit old, and the problem may have been fixed since. A new version should come live in the F-Droid repositories soon: see (by searching the page for “ring” (the old name of jami) you can see the package successfully built).


I tried the Aurora store version but the issue persists. I tried toggling my VPN on and off but that didn’t help either.

Well then I don’t know why you are having this issue, I will let a developer answer that question :slight_smile:
It is maybe relatred to this issue: Android beta: No "online" status (green dot), can't send file (#994) · Issues · savoirfairelinux / jami-client-android · GitLab

Ok, thanks for the suggestions though. I’m trying to figure out if it’s something to do with my configuration or a more general Android/F-Droid problem. Given your link maybe it is more of a general problem.

It’s a shame as since Swarm, on iOS anyway, I’ve been thinking how nice it is that Jami seems so much more reliable now.

I’ve tried a couple of other Android devices and they’re working fine, syncing, sending & receiving, so it looks like it’s just this one device, not a general problem.

I take that back. They’ve all stopped again. No syncing, sending or receiving or calls.

Do you have Turn enabled (all devices)?


I’ve tried toggling on and off the various server options which didn’t seem to help, however, it is now working. I’m not sure why.

There was an update available in the Aurora Store (dated 13 December) which I downloaded and it all seems to be working now.

One strange thing, I deleted a problematic contact, intending to re-add them, but after deleting the contact, they were still there and then the conversation synced. Not sure what that was about.

1 Like

Ok. It’s not working again. The device is a degoogled device running CalyxOS. Not sure if that’s a problem. Am running it on another device without Google and seems to work ok.


I’m not sure what may be going wrong, but I’d appreciate it if you could please open a bug report at with as much details as possible.

Ok, thanks. Have done it. Issue #1057.

I’ve tried to isolate the environment, but Jami is running fine on other Android devices both with, and without, Google services installed.

1 Like