Audio/Video calls on separated network

I would like to make audio calls and later also video calls using Jami on a separated office network.
My network does not connect to the Internet.
The network consists of several PCs and Macs.
The hosts are connected with a switch and they are all on the same subnet.
I have installed Jami and I am able to have text conversations among the connected machines.
When I try to start an audio call from host (1), host (2) does not receive the call, so I am unable to answer it.
The same is true from host (2) to host (1).
How can I setup my network so I can have audio calls between the hosts?

without log/version it’s pretty like playing with a magic ball.

FAQ — Jami documentation may help

Correct. my bad.

The version is:
On windows 10: Taranis, 2022 10 28 1424
On OSX 12.0.1: Taranis, 2022 10 21 1317

The logs are: (approximately)
[sipcall.cpp: 1844] [call: 71…67] ICE initialization time was unexpectedly high (33100ms)
[sipcall.cpp: 1858] [call: 71…67] The call was terminated while waiting for ICE initialization
[ice_transport.cpp] [ice: 000…F30] Destroying ICE_strans

Looking at the FAQ did not help.
I have enabled the option “Enable local peer discovery” in the settings,
But the calls still failed.
both hosts can still communicate using text messages. But no sound calls.

Should I run a SIP server?

what’s the TURN address? For a ICE initialization timeout, it’s probably a resolution error on something.

sblin, thank you for help.
The sound calls work now.

For those who want to know what went wrong and what I did:
In the Account settings page, the “Use TURN” option was enabled and configured.
Because of that, probably, the ICE could not connect (I’m inside a network that is separated from the internet)
As soon as I disabled the “Use TURN” option, the sound calls were able to connect.
I now have sound calls working, both ways, even between 3 hosts.

I did need to restart the app a few times after I connected the external microphone until the app understood that I want to use it. Now it works.

I did not mention that before, but I also have an OpenDHT dhtnode running on the OSX host.
All other Jami stations are configured to bootstrap from that OSX machine.

For now, text chats and voice calls are working fine.
Thank you for your help.

Actually, this can be enabled if your version is > to 20221213.