Call from Android to Android only works on the same network

Hello to all jami users,

I have noticed a problem with the current Android version. When I make a phone call from Android to Android, it does not work unless the devices are dialed into the same network. Otherwise, for example, it always works reliably when I want to call from Windows (with the current Jami version) to an Android device even when they are not on the same network. Will this problem be fixed at some point?

Best regards from Christoph.

Jami version: Maloya - 20210521-01 (Android)
Mobile operating system: Android 10

Jami version PC: Maloya 202106031831
Windows version: Windows 10

What are your settings on the Android device under Accounts → Advanced

My settings are in german. I hope it still helps.



It doesn’t seem to be a network issue. It seems that I have to open the App and let it be in the front on android so that it works. This makes me think if this has to the with the battery management of android and how Jami deals with it.

Few things

  1. Disable DHT proxy - you may not need it.

  2. Go to Jami settings by clicking on the top right corner, in that menu Enable Run Jami in background

  3. Depending on your Android phone it may still kill the app when you are idling, so go to Phone settings → Battery settings->Apps->Jami and make sure it is not killed for battery optimisation

checkout dontkillmyapp.com for handset specific locations where the settings are located for disabling battery optimisation for Jami app

1 Like

I’d generally suggest keeping DHT proxy enabled on mobile devices; since among other things, it helps lessen the battery usage.

1 Like