I get "Missed Incoming call" when dialling out on SIP

I’ve installed a fresh Jami on my Ubuntu box (22.10) and configured the SIP server. I get the green dot that it has connected to the SIP server.

When I try to make a call using Jami, it doesn’t connect but immediately shows “Missed Incoming Call”. It is clearly doing something at the server end, as I get an e-mail notification that there was a missed call, to itself.

Any ideas what to check?

it’s a string issue that will be fixed in next version. But the call should still work (and is an outgoing call). Logs may help

I found the problem and it is to do with Calling Line Identification (CLI). Seems that by default, the Jami client presents a CLI that the server does not like.

I managed to get around it by setting the SIP server to manually present a CLI, rather than take it from Jami.

Ideal would be for a Jami client option to not present any CLI, or to have a specific field where it can be specified manually. At present, there seems to be no way to configure this on the Jami client.