Jami android connectivity issue

I’m trying since many years to use Jami on android. I notice some improvements. But for my friends who use other OSes I’m always offline, even though my account is online.
Jami start on boot and run in background enabled, battery optimization disabled…
To be able to send and receive calls and messages I must refresh my account (off it, on again then wait).
Jami Developer Team, could you make accounts always actually online on android devices so that users don’t miss calls and messages?
Thank you

I think these issues are already reported:

Thank you for the information.

Hi,
I’ve seen this happen already since years ago. even before changing to swarm.

(a) Windows10Qt client - on LAN via cable
(b) /e/os android - on LAN via wifi
(c) samsung android - via 4G
All running taranis version.
All clients have been in this network configuration for at least about 8 hours.

  • (b) sent message to (a). (a) doesn’t receive it.
  • (c) sent message to (a). (a) doesn’t receive it.
  • (a) puts identity offline and online again. it still doesn’t receive the messages.
  • (b) puts identity offline and online again. Now (a) does receive the messages of (b)
  • (c) puts identity offline and online again. (a) does not receive the messages of (c)
  • (c) puts identity offline and online again. Now (a) does receive the messages of (c)

There’s seems to be an issue on both the receiving and sending side, where the identity must be put offline and online again.
i do have logging option on the QT client. But on the android side, i have no clue how to obtain logging. How can i help finally getting to the core of this issue?

Do you have Turn enabled (all devices)?

It is described here (“On Android”):

Ideally get the logs (remove personal informations like your identifier, your friends etc.)
Please report this issue using Gitlab:

@rtwin Maybe these tutorials can help:

Thanks for the extra info.

On all 3 devices i have;

  • UPnP On
  • DHT-Proxy On (default address)
  • Discover local nodes On
  • Stun Off
  • Turn On (default address)

in all chats, i’ve checked for them to be private swarm chats.
It’s (this setup)

Try to get the logs (remove your personal data like identifier) and report this issue using Gitlab.

1 Like

In Linux I had to employ a workaround, making Jami re-start every 20 minutes to reduce the offline time.