Jami not working

Jami by default does not work for most people to send and receive messages. I followed this to enable public DHT. Nothing happened other that I can see on one device when the other device is typing but it never receives the message.

My test situation:

  • Device 1 = android tablet on one side of Atlantic with account 1
  • Device 2 = Debian with desktop client on the other side of Atlantic with account 2

Account 1 sees account 2 green and vice versa.

Both have public DHT proxy enable and set according to the link above.
When typing on Device 1, Device 2 displays that device 1 is typing but after device 1 has sent the message, the message does not appear on device 2.

When device 2 is typing, no indicator is shown on device 1 that device 2 would be typing. When device 2 sends the message, no message is received on device 1.

All this tested with new accounts and fresh installations of the jami. The network settings (firewall etc) is beyond my access on device 2 side. On device 2 side, i can connect to expressVPN network to surpass any limitations that are on that side of that network, but i am still not with public ip or ability to manage NAT.

I have no access to public IPs!

Can Jami work in this case? If so, how do i make it work?

1 Like

Jami can use TURN server (Compared to UDP-based ICE, ICE TCP has, in general, lower success probability for enabling connectivity without a relay if both of the hosts are behind a NAT or a firewall. But swarm need TCP as yet), you can use the default TURN server (turn.jami.net) or setup your own TURN server.

I do hope that Jami will add a UDP-based reliable transport. :pray:

1 Like