Jami won't start (arch/EndavourOS)

Enviroment: EndavourOS latest.
First I downloaded Jami daemon an Jami qt, reboot the laptop, tried to start jami, it was loading for short time but nothing, failed to show the interface. If I try to start it from terminal, I get this:

“notify server name: Plasma, vendor: KDE, version: 5.26.3, spec: 1.2”
qt.webenginecontext:

GL Type: desktop
Surface Type: OpenGL
Surface Profile: CompatibilityProfile
Surface Version: 4.6
QSG RHI Backend: OpenGL
Using Supported QSG Backend: yes
Using Software Dynamic GL: no
Using Multithreaded OpenGL: yes

Init Parameters:

  • application-name Jami
  • browser-subprocess-path /usr/lib/qt6/QtWebEngineProcess
  • create-default-gl-context
  • disable-features ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture
  • disable-setuid-sandbox
  • disable-speech-api
  • enable-features NetworkServiceInProcess,TracingServiceInProcess
  • enable-threaded-compositing
  • in-process-gpu
  • use-gl desktop

“Using locale: en_US”
19:04:03.064 os_core_unix.c !pjlib 2.11 for POSIX initialized
Daemon is running
No migration required
Segmentation fault (コアダンプ)

Again no gui loaded, what to do?

can you get a baccktrace (and start with -d?) also what version is it (not provided by jami.net)

jami-daemon 20220722-6
jami-qt 20220726-1

Tried to start again and got this:

“notify server name: Plasma, vendor: KDE, version: 5.26.3, spec: 1.2”
qt.webenginecontext:

GL Type: desktop
Surface Type: OpenGL
Surface Profile: CompatibilityProfile
Surface Version: 4.6
QSG RHI Backend: OpenGL
Using Supported QSG Backend: yes
Using Software Dynamic GL: no
Using Multithreaded OpenGL: yes

Init Parameters:

  • application-name Jami
  • browser-subprocess-path /usr/lib/qt6/QtWebEngineProcess
  • create-default-gl-context
  • disable-features ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture
  • disable-setuid-sandbox
  • disable-speech-api
  • enable-features NetworkServiceInProcess,TracingServiceInProcess
  • enable-threaded-compositing
  • in-process-gpu
  • use-gl desktop

“Using locale: en_US”
09:35:42.842 os_core_unix.c !pjlib 2.11 for POSIX initialized
Daemon is running
No migration required
could not update message status for not existing conversation
could not update message status for not existing conversation
could not update message status for not existing conversation
could not update message status for not existing conversation
could not update message status for not existing conversation
could not update message status for not existing conversation
could not update message status for not existing conversation
could not update message status for not existing conversation
could not update message status for not existing conversation
could not update message status for not existing conversation
Syncing lrc accounts list with the daemon
Screen saver dbus interface: “org.freedesktop.ScreenSaver”
QQmlApplicationEngine failed to load component
qrc:/src/app/MainApplicationWindow.qml:108:5: Type DaemonReconnectPopup unavailable
qrc:/src/app/commoncomponents/DaemonReconnectPopup.qml:26:1: Type BaseModalDialog unavailable
qrc:/src/app/commoncomponents/BaseModalDialog.qml:109:5: Type DropShadow unavailable
qrc:/qt-project.org/imports/Qt5Compat/GraphicalEffects/DropShadow.qml:6:1: Cannot load library /usr/lib/qt6/qml/Qt5Compat/GraphicalEffects/private/libqtgraphicaleffectsprivateplugin.so: (libQt6ShaderTools.so.6: cannot open shared object file: No such file or directory)
Main window loaded using OpenGLRhi
NetworkManager client initialized, version: 1.40.2 , daemon running: yes , networking enabled: yes
primary network connection: 91b51ef2-5f54-4229-ac22-84c2f150b254 default: yes
Segmentation fault (コアダンプ)

Seems to me daemon is running but there are problems with qt.
How to start with -d and get the backtrace?

no need for more info. you will need “qt6-5compat” (on debian it’s qml6-module-qt5compat-graphicaleffects) (also if “jami -d” doesn’t start the logs of the daemon, it means that your client is not using libwrap but dbus (it may be wanted, but on jami.net we use libwrap by default)).

1 Like