Mac Audio Input Selection

Thanks everybody for your effort for a sustainable future.

I’m using Jami on a Windows PC and on a Mac since a few weeks, have tried out many things with these two devices, what resulted in many crashes, most of them on the Mac. The more I’m learning, the more I’m starting to see a little bit of the complexity of the entire thing, what seems to be far beyond my imagination. I guess that the stability issues are going trough multiple processes, therefore it must be hard to find out the causes, and even much harder to find the most appropriate corrections. Last but not least, it is basically working, and I’m looking back to a lot of wonderfully fearless times, please take my greatest thanks and respect.

There is one thing, that is at least simple to describe, not all audio devices are being listed in the selection. There is a microphone built in an Aukey USB camera, and another one on a Logitech USB wireless headset, both being listed in Jami. Much better than those is such as a Focusrite professional quality audio interface, with level indication and classical volume knobs. Yes, it is basically made for home recording, for the use with such microphones, can be used with Jami on Windows. It is on the backend side still an ordinary USB stereo I/O audio device, using nothing but an OSx standard driver, just like the other two.

So what’n that?
What’s the difference?
Why can two OSx audio drivers be listed, and the third one not?

For the future, I would like to be able to play some music from any source, mixed with my own contributions, what needs some kind of audio mixer, such as Background-Music. Therein, all the microphone sources are appearing, together with the entire list of sources from apps, to mix down in an output, being listed everywhere else as a virtual audio device, as yet another selectable source. But guess what, there is a resisting little village by the name of Jami, seemingly refusing to accept any virtual mixing and/or loopback devices. I’ve tried quite a few of them, without finding yet any, that could be used with Jami. And yes, there are two among them, made by some developer by the name of Apple, who is not known to be a random semi amateur backyard company. Those can be created in the Audio-Midi-Setup program, that belongs to the OSx, are working almost everywhere, one will already have guessed, with the exception of Jami.

Could there any logical sense be found?

Thänks in advance for equality among users and producers and products.

1 Like

Someone juste opened a bug report for your issue on the jami bugtracker here, in case you want to know:

I am not a developer, but I know that the Jami team is working hard at the moment to release a completely new version for macos soon :slight_smile:.
I’ll let the developers answer, but the bugs might get fixed with this new version, when it will be released :slight_smile:.

I guess that this is not any kind of bug, but filtered out deliberately, meant to be supportive for those who don’t know the names of their hard- and software…

thänks a lot for remembering the developer, is giving me hope