Neither camera nor chat window work [on Linux]


I have tried installing jami with the command line (sudo apt-get install jami), via Aptitude and by sudo dpkg -i “.deb-file” but regardless of the alternative, jami will not register my camera and I cannot chat with my contacts. I get a notification when I recieve new messages from contacts, but I cannot open them and the jami window is just blank. I managed to get the camera to work once after installing the .deb-file but now not even that works.

I’m running Gnome, Debian Buster (10) stable on a ThinkPad L390. Any help would be appreciated!

Update: When I run the command “sudo apt install gnupg dirmngr ca-certificates curl” from the debian 10 installation guide I get the following message:

“The following packages could not be satisfied:
curl : Dependent on: libcurl4 (= 7.64.0-4+deb10u1) but 7.68.0-1 will be installed”



That’s a strange dependency-related error you’re seeing when doing sudo apt install gnupg dirmngr ca-certificates curl, and actually nothing about those packages is Jami-specific. I think this hints at a broken set of packages on your machine and/or on the Debian side (which I’d imagine would be only temporary, given the importance of those packages and that the Debian folks are very serious about not breaking anything).

Perhaps try sudo apt update, optionally do sudo apt upgrade to bring all your packages up-to-date, and then try installing those four packages and see if it works this time around.

As for the Jami issues you described, unfortunately I cannot tell anything without knowing the version you’re using and without looking at some logs. Please see for details on how to report a bug, including instructions for gathering logs from the Jami daemon and the Jami client you are using.


Thanks for replying!

I realised I should have installed jami from the Debian stable repositories instead of the nightly jami version. I had to downgrade some dependencies to get the jami 2019-02-15 version working. Don’t know how I could not have thought of that the first time… Unfortunately however this was not enough. I still cannot the what I write in the chat window or what my contact writes, and the camera still is not working in Jami.

I’ll go through the guide you linked – thanks!

Actually, at the moment we highly recommend installing Jami from our ‘nightly’ repos on, because the version of the Jami included in the current Debian stable release (buster) is very out of date (it’s from nearly two years ago), and there have been many improvements and fixes to Jami ever since.

I have been working on getting Debian’s Jami package updated for a few months now, but it’s still a work-in-progress, and in the meantime I highly recommend using new versions of Jami distributed via our repos on

Please uninstall the Jami version you installed from Debian’s own repos, and instead try installing it like this:

sudo apt update && sudo apt upgrade
sudo apt install gnupg dirmngr ca-certificates curl --no-install-recommends
curl -s | sudo tee /usr/share/keyrings/jami-archive-keyring.gpg > /dev/null
sudo sh -c "echo 'deb [signed-by=/usr/share/keyrings/jami-archive-keyring.gpg] ring main' > /etc/apt/sources.list.d/jami.list"
sudo apt update && sudo apt install jami

And thanks, indeed knowing more about exactly what is failing and how would greatly help us try and troubleshoot it. :slight_smile:


1 Like