New user with video problem

Hello to the list members,
I am new to Jami and also to Linux so please be patient with me. I installed Mint 19.2 and tested Jami on my home wifi with another laptop running Win 11 and everything worked as expected. However with this same Win 11 laptop as well others on different platforms outside my local network I cannot see their video or my own. They can see me and themselves on their respective machines. I am wondering if this is an issue with port permissions on this laptop? I tried to configure a rule for the firewall but don’t know if I did that right. The issue remains with firewall turned off. Can anyone make a suggestion?

Thanks in advance


Are you both on the same home network ?

For far as i know , you don’t have to open ports in your router.

What you can try is enable upnp in your router.
Jami can then open ports with upnp .
But it is not a need, if all options not work, Jami use turn protocol with the turn servers from Jami.

Maybe you can look in your windows and Linux mint fire wall.

Thank you M1k4,

Yes the initial test was side by side on a table on same wifi network. I admit that I don’t understand a lot about the technical details of the different connection types. The other users I want to connect with I’m sure know even less. The problem came after trying to connect from different locations. I had initially installed jami with these instructions:

sudo apt install gnupg dirmngr ca-certificates curl --no-install-recommends
curl -s | sudo tee /usr/share/keyrings/jami-archive-keyring.gpg > /dev/null
sudo sh -c “echo ‘deb [signed-by=/usr/share/keyrings/jami-archive-keyring.gpg] jami main’ > /etc/apt/sources.list.d/jami.list”
sudo apt-get update && sudo apt-get install jami

This installed a gnome client. After struggling with these connection problems I tried using the snap install afterward which installed a different version. This version is able to connect through the TURN server but is very erratic and unreliable. The video and audio works sometimes and not others. I am not sure if this is because I didn’t properly remove the original install or something else? Two other things I wonder may be a factor.

  1. This is an old machine and I see that Jami uses a lot of its available resources.
  2. The current wifi signal is marginal but I will be improving that this week.

How can I be sure the gnome client version is fully removed and is not messing things up with the snap version? Or it could be something else of which I am ignorant. I have a lot to learn about Linux.