No message notification & Unjoinable peer

Just doing a real life test with a colleague - both on android, a couple of points so far. Both running android

  • No notifications of new messages - having to rely on swarm update when manually opening Jami
  • The dreaded “Unjoinable Peer” when trying to download a picture after a swarm update - I assume the other peer is offline. No way of retrying.

Which versions (Jami and Android) are you using?

I’m using android 11 and Jami 20230119-01

This morning I met my other tester and confirmed they had not switched off their mobile - so was on. We tried sending about 20 messages again this morning but none were received on either handset. Both android handsets had a good LTE signal.

Does it change anything if you enable/ disable turn?

I think this issue is similar to these issues:

My test colleague is out the office today, should be in tomorrow.

Will try Jami - Android 12 - Requires Toggling Online/Offline (Enable/Disable) (#1395) · Issues · savoirfairelinux / jami-project · GitLab

Although I havent tried with my test colleague. I have tried with a windows 10 and Android. I’m getting very good performance if on android I goto Advanced settings > enable “Run in background”. I have sent messages and files between android and windows 10 all day with no performance issues. Even when out of the office all working ok. The battery usage seems OK still

I will continue trying for the week to make sure all is OK then will try connecting thre android to Wifi - will then check performance with the adroid switching between 4G and Wifi.