Outgoing SIP calls drop after less than one minute

Hello,

I am using an OVH SIP account.

Outgoing calls to another OVH SIP account or to a landline are dropped after 33s with the latest version of Jami from F-Droid running on LineageOS and after 14s with Jami on Trisquel 9 (Ubuntu-based but removing any option to add non-free software) from the Trisquel repository, dated 2020-03-24. This is 100% reproducible.

Incoming calls don’t have that problem.

Any idea what the issue could be and how to solve it?

2020-03-24 is too old, use a recent one. We provide packages there: https://jami.net/download-jami-linux/

The problem occurs with 20201222-01 on LineageOS 17.1-20211019-NIGHTLY-lavender

EDIT: I tried with 2021-01-15 22:14:51 UTC on Trisquel, the outgoing calls are now dropped after 32s instead of 14s before. 100% reproducible as well.

In this case, open a bug report with logs https://git.jami.net/savoirfairelinux/ring-project/-/wikis/tutorials/Bug-report-guide#logs

Bonjour , j’ai le problème de déconnexion quand j’appelle des numéros de téléphones fixes , j’ai un compte OVH SIP et on peut m’appeler sans problème mais quand j’essaye d’appeler la ligne se déconnecte systématiquement au bout de 32 secondes voici mes logs mars 28 16:22:46 dring[10507]: Not using hardware decoding for pcm_mulaw
mars 28 16:23:18 dring[10507]: Unbind call 4858176655039542 from all bound calls
mars 28 16:23:18 dring[10507]: [call:4858176655039542] removeCall()
mars 28 16:23:19 dring[10507]: Couldn’t read frame: Operation not permitted
mars 28 16:23:19 dring[10507]: PublishMapSubject: detaching observers
mars 28 16:23:19 dring[10507]: PublishMapSubject: detaching observers
mars 28 16:23:19 dring[10507]: Destroy RingBuffer 4858176655039542
mars 28 16:23:19 dring[10507]: ~PublishMapSubject()
mars 28 16:23:19 : PublishMapSubject: detaching observers
mars 28 16:23:19 dring[10507]: ~PublishMapSubject()
mars 28 16:23:19 dring[10507]: PublishMapSubject: detaching observers

bon je me réponds à moi même je pense qu’il faut faire ça snap connect jami:alsa ça doit être un problème de droits , salut les amis

OK so it does not work , here my config

accounts:

  • id: “-----”
    alias: SIP
    enable: true
    type: SIP
    activeCodecs: 27/139/12/4/65543/65542/69660/86076/536956963/
    mailbox: “”
    autoAnswer: false
    rendezVous: false
    activeCallLimit: -1
    ringtoneEnabled: true
    ringtonePath: /usr/share/ring/ringtones/default.opus
    hasCustomUserAgent: false
    useragent: “”
    displayName: SIP
    hostname: “-----”
    upnpEnabled: true
    audioPortMax: 32766
    audioPortMin: 16384
    dtmfType: overrtp
    interface: default
    publishAddr: “”
    publishPort: 5060
    sameasLocal: true
    videoEnabled: true
    videoPortMax: 65534
    videoPortMin: 49152
    stunEnabled: false
    stunServer: “”
    turnEnabled: false
    turnServer: “”
    turnServerUserName: “”
    turnServerPassword: “”
    turnServerRealm: “”
    bindAddress: “”
    port: 5060
    username: “-------”
    credential:
    • Account.password: “---------”
      Account.realm: “*”
      Account.username: “--------”
      keepAlive: true
      presenceModuleEnabled: false
      presencePublishSupported: false
      presenceSubscribeSupported: false
      registrationexpire: 60
      serviceRoute: “”
      tls:
      calist: “”
      certificate: “”
      password: “”
      privateKey: “”
      enable: false
      tlsPort: 5061
      verifyClient: true
      verifyServer: false
      requireCertif: true
      timeout: 2
      ciphers: “”
      method: TLSv1
      server: “”
      srtp:
      keyExchange: “”
      rtpFallback: false
      preferences:
      historyLimit: 0
      ringingTimeout: 30
      historyMaxCalls: 20
      md5Hash: false
      order: 764f0ddf625fbbe6/
      portNum: 5060
      registrationexpire: 180
      searchBarDisplay: true
      zoneToneChoice: North America
      voipPreferences:
      disableSecureDlgCheck: false
      playDtmf: true
      playTones: true
      pulseLength: 250
      symmetric: true
      zidFile: “”
      audio:
      alsa:
      cardIn: 0
      cardOut: 0
      cardRing: 0
      plugin: default
      smplRate: 44100
      alwaysRecording: false
      audioApi: pulseaudio
      automaticGainControl: false
      captureMuted: false
      noiseReduce: false
      playbackMuted: false
      pulse:
      devicePlayback: “”
      deviceRecord: “”
      deviceRingtone: “”
      recordPath: “”
      volumeMic: 1
      volumeSpkr: 1
      echoCanceller: system
      video:
      recordPreview: true
      recordQuality: 0
      decodingAccelerated: true
      encodingAccelerated: false
      conferenceResolution: 1280x720
      devices:
    • name: “Integrated_Webcam_HD: Integrate”
      id: CNFHH46P0334103446A0_Integrated_Webcam_HD_200901010001
      input: /dev/video0
      video_size: 960x540
      channel: Camera 1
      framerate: 30
      plugins:
      pluginsEnabled: false
      loadedPlugins:
      []
      shortcuts:
      hangUp: “”
      pickUp: “”
      popupWindow: “”
      toggleHold: “”
      togglePickupHangup: “”

please What is wrong in my config ? I have still the line is out after 32 seconds ?

this is not the same as this one test/sip/dring-sample.yml · e34f3ca7bc1b4b8cd28f39c897d197602b4ece93 · savoirfairelinux / jami-daemon · GitLab

accounts:

  • id: IP2IP
    alias: IP2IP
    enable: true
    type: SIP
    allCodecs: 1/2/3/4/5/6/7/8/9/10/11/
    mailbox: “”
    autoAnswer: false
    activeCallLimit: -1
    ringtoneEnabled: true
    ringtonePath: /usr/share/ring/ringtones/default.wav
    hasCustomUserAgent: false
    useragent: Ring/3.0.0
    displayName: “”
    hostname: “”
    upnpEnabled: false
    audioPortMax: 32766
    audioPortMin: 16384
    dtmfType: overrtp
    interface: default
    publishAddr: “”
    publishPort: 5060
    sameasLocal: true
    videoEnabled: true
    videoPortMax: 65534
    videoPortMin: 49152
    stunEnabled: false
    stunServer: “”
    turnEnabled: false
    turnServer: “”
    turnServerUserName: “”
    turnServerPassword: “”
    turnServerRealm: “”
    port: 5060
    username: “”
    credential:
    • Account.password: “”
      Account.realm: “*”
      Account.username: “”
      keepAlive: false
      presenceModuleEnabled: false
      presencePublishSupported: false
      presenceSubscribeSupported: false
      registrationexpire: 60
      serviceRoute: “”
      tls:
      calist: “”
      certificate: “”
      password: “”
      privateKey: “”
      enable: false
      tlsPort: 5061
      verifyClient: true
      verifyServer: false
      requireCertif: true
      timeout: 2
      ciphers: “”
      method: TLSv1
      server: “”
      srtp:
      keyExchange: “”
      rtpFallback: false
      preferences:
      historyLimit: 0
      historyMaxCalls: 20
      md5Hash: false
      order: IP2IP/
      portNum: 5060
      registrationexpire: 180
      searchBarDisplay: true
      zoneToneChoice: North America
      voipPreferences:
      playDtmf: true
      playTones: true
      pulseLength: 250
      symmetric: true
      zidFile: “”
      hooks:
      numberAddPrefix: “”
      sipEnabled: false
      urlCommand: x-www-browser
      urlSipField: X-ring-url
      audio:
      alsa:
      cardIn: 0
      cardOut: 0
      cardRing: 0
      plugin: default
      smplRate: 44100
      alwaysRecording: false
      audioApi: pulseaudio
      automaticGainControl: false
      captureMuted: false
      noiseReduce: false
      playbackMuted: false
      pulse:
      devicePlayback: “”
      deviceRecord: “”
      deviceRingtone: “”
      recordPath: “”
      volumeMic: 1
      volumeSpkr: 1
      video:
      decodingAccelerated: true
      devices:
    • framerate: 30
      channel: Camera 1
      name: “Integrated Camera: Integrated C”
      video_size: 960x540
    • framerate: 30
      channel: Camera 1
      video_size: 800x600
      name: Logitech BRIO
    • framerate: 30
      name: Integrated Camera
      video_size: 960x540
      channel: Camera 1
      shortcuts:
      hangUp: “”
      pickUp: “”
      popupWindow: “”
      toggleHold: “”
      togglePickupHangup: “”