Problems with building Jami from source

I followed the instructions Build instructions · Wiki · savoirfairelinux / jami-project · GitLab to build Jami quickly from source on my Fedora 33. I have two problems:

  • When I click on the Jami, nothing happens, the program doesn’t start
  • 3 programs that I don’t know of where installed and now appear in the applications menu

It is a little bit weird for me, so if someone could help me out it would be great :slight_smile:
Moreover, I noticed that in the download section, Fedora 33 is not mentionned. Finally it would be cool to have Jami packaged in the official repos of Fedora, or at least in the rpm fusion free repo. Because I tried to use the package from flathub, but experienced a lot of bugs and crashes.

P.S.: You can also help me out in french if you prefer, as I speak both :wink:

For the first problem start via the cli and check the output to have logs. Also does /usr/local/lib/ring/dring exists? or similar. Where did you install daemon + client?

the other software are not related to jami but seems from dbus-c+±devel (because you built it from sources, you need to install dbus-c+±devel) cf

dnf provides /usr/bin/elementary_test 
Last metadata expiration check: 0:11:48 ago on Tue 23 Feb 2021 03:53:12 PM.
efl-1.25.0-1.fc33.i686 : Collection of Enlightenment libraries
Repo        : fedora
Matched from:
Filename    : /usr/bin/elementary_test

 amarok@tars3  ~/Projects/opendht/build   master  dnf remove efl                       
Dependencies resolved.
 Package                                                                              Architecture                                                         Version                                                                               Repository                                                              Size
 efl                                                                                  x86_64                                                               1.25.1-4.fc33                                                                         @updates                                                                46 M
Removing dependent packages:
 dbus-c++-devel                                                                       x86_64                                                               0.9.0-23.fc33                                                                         @fedora                                                                 90 k

We don’t provide any flathub repo from but we provide our own fedora 33 repo.

1 Like

jami-gnome: error while loading shared libraries: cannot open shared object file: No such file or directory

And yes : /usr/local/lib/ring/dring exists

I get this view when I am on Download Jami for GNU/Linux :

I pingued back the team for but just (same as fedora_32/31/30, but just replace by 33)

sudo dnf config-manager --add-repo
sudo dnf install jami cannot open shared object file:

This means it’s not installed. I’m sure that you just didn’t do a global install (the build page is long, what exact commands did you type?). By default building doesn’t mean global installing. Check where you install files. But I highly not recommend building if you don’t check your build and just want to use it, there is repo for that. Else it’s the easy way to just have a dirty env. If you do a ./ --run, at least does it runs? by default all files are in jami-project/install. So will be in YOURPATH/jami-project/install/lrc/lib/

I ran that
git clone
cd ring-project/ ./ --init
./ --dependencies
./ --install --global-install

still don,t know where the files are installed. Check the logs. Also you may have another version installed (from a previous repo) and not cleaned correctly.

locate can help

I had still jami installed from flathub, maybe it’s the issue ^^ No I uninstalled the flathub version, and when I type locate nothing happens.

Which logs do you mean?

In any case, thank you very much for taking the time to help me :slight_smile:

the logs of the build to know where you install your files. For now I still don’t know where you installed

So now jami starts well, it is located in /bin/bash/usr/local/bin/jami :slight_smile:

I get this message when starting jami from the command-line
QDBusMarshaller: type VectorString' attempts to redefine basic D-BUS type 'as' (QStringList) (Did you forget to call beginStructure() ?) QDBusMarshaller: type MapStringVectorString’ produces invalid D-BUS signature a{s}' (Did you forget to call beginStructure() ?) QDBusMarshaller: type QMap<QString,MapStringVectorString>’ produces invalid D-BUS signature `a{s}’ (Did you forget to call beginStructure() ?)

(jami-gnome:40172): Gtk-CRITICAL **: 10:12:27.003: gtk_scrolled_window_add: assertion ‘child_widget == NULL’ failed

(jami-gnome:40172): Gtk-WARNING **: 10:12:27.096: Theme parsing error: :1:270: not a number

And it says also that it’s the development version. So it’s not the stable release as I could get it in the official repo?

it’s ok, but what was the error?

Also if you want another version just choose the branch you want in the repo

I don’t really know what was the error, maybe it was the flatpak version interfiering…