Sadly had to abandon Jami due to lack of notifications

I tried out Jami because I wanted a way for a script on my desktop (Linux) to alert me on my phone (Android). Unfortunately even with LAN discovery turned on, it barely worked. Linux would send messages but they would stay grey; sometimes when I opened the app on the cellphone, a whole string of notifications would come in at once. I have switched to the XMPP protocol, using “Dino” on Linux and “Xabber” on Android, and it works fine now. I have to suspect that it’s something to do with the way Android handles processes in the background. My phone warns me that Telegram, Xabber and other programs are “running in the background” but I NEVER had this message for Jami. Perhaps Jami isn’t correctly asking Android to stay running when the app is closed? (It didn’t matter if I left the app open, or closed it, neither worked.) I really wish you “Bonne Chance” with your project as I love the concept, but it was no use for my requirement since the notification was the main purpose.

Settings->“Run in background” (Allow running in background…)

1 Like

Thank you for answering; if that is the simple reason why Jami didn’t work, I suggest that it should be the default behaviour. It seems sad to write such a complex and clever program, and then have it not work because something isn’t enabled. How many people have installed Jami, found it unreliable and simply uninstalled it again? Not many people come to the forum to give feedback.

Yes, great that this is all configurable! But all this should be on by default for the non-technical user.