Screen is turned-off every 10' during videocalls (GNU+Linux/Windows)

Hi, my wife is a musician and gives piano and singing lessons through Jami.
We use various distros (right now, Debian and Arch) and her students mostly Windows and some the Apple one (don’t know which version/name they use right now).
Because of the nature of the activity the computer doesn’t get any hardware input activity during the videocall (no keyboard input, nor mouse, etc.). In all the systems, both my wife and her students, they get the screen turned-off each 10 minutes.
I’ve been looking around in the settings and Internet search engines but couldn’t figure out how to solve/modify this behavior. Any idea?
Thanks a lot in advance!

Which package are you using (version and origin) ?

1 Like

For Linux it’s usually a DPMS setting, plus your window manager/compositor might have its own setting. For Windows you can probably find it in the control panel under power management (or maybe screen saver).

Basically it’s a system setting that will be different for each system.

1 Like

Right. I believe both the older jami-gnome and the newer jami-qt client try to inhibit the screensaver when in calls, but perhaps it’s not taking precedence. I’d recommend checking your screensaver and/or display settings.

If you could tell us the exact version numbers of Jami being used, and for GNU/Linux the name and version of the distribution you use, we may be able to help test/verify/debug.

2 Likes

This is in updated Debian 11 (Stable/Bullseye):

$ apt-cache policy jami jami-daemon 
jami:
  Instalados: 20210112.2.b757bac~ds1-1
  Candidato:  20210112.2.b757bac~ds1-1
  Tabla de versión:
 *** 20210112.2.b757bac~ds1-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
jami-daemon:
  Instalados: 20210112.2.b757bac~ds1-1
  Candidato:  20210112.2.b757bac~ds1-1
  Tabla de versión:
 *** 20210112.2.b757bac~ds1-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status

But the issue appears also in Windows with Jami just downloaded and installed, so, I’m pretty sure the students are using the last version from official website.
I’m gonna test the issue with the Arch package ASAP and inform. Thanks!

Also: @bandali, hope this info is useful. Thanks a lot!

From what I see you are using a very old package 2021 01 12 (so january 2021) from the official Debian repository. With the version from the official Jami repo, you should have a way better experience :smiley: