Snap connect jami:alsa (Raspberry PI 400 installation)

I am getting tons of errors with a Raspberry PI 400 installation.

Lets begin with this:

snap run jami

I wonder why snap doesn’t install an executable programm, eg like firefox snap does.

You can also grant this permission by running the following command 
in a Terminal window:

sudo snap connect jami:alsa

I tried this

snap "jami" has no plug named "alsa"

This doesnt work. So I tried

sudo snap install alsa-utils
alsa-utils 1.1.2-5 aus Canonical✓ installiert

Again I see:

sudo snap connect jami:alsa

If I choose “a” jami starts with a lot of errors.

Type [p] to re-test after granting [p]ermission,
     [s] to [s]tart and not ask again,
     [a] to start and [a]sk again next time, or
     [c] to [c]ancel (default)

permission | start | ask | [cancel] > a...use PulseAudio this time and ask next time.
Gtk-Message: 17:29:40.564: Failed to load module "xapp-gtk3-module"
** Message: 17:29:40.570: Jami GNOME client version: development
** Message: 17:29:40.570: git ref: ...
Jami Daemon 9.5.0-1d2a757faa-dirty, by Savoir-faire Linux 2004-2019
[Video support enabled]
[Plugins support enabled]

Interesting seems to be:

(jami-gnome:5771): Gtk-CRITICAL **: 17:29:48.289: gtk_scrolled_window_add: assertion 'child_widget == NULL' failed
Gtk-Message: 17:29:49.157: Failed to load module "xapp-gtk3-module"

(jami-gnome:5771): Gtk-WARNING **: 17:29:49.334: Theme parsing error: <data>:1:270: not a number

Does Jami run on a Raspberry without problems? Don’t know where to start.

I think there is no build for raspbian since a very very long time. Moreover the GNOME client is not maintained since a long time now. I guess the best way for rasp would be to cross-compile from source as the version available will not work

1 Like