Ubuntu build jami project

hi, i try to build jami project with ubuntu 22, i follow manual until ./build.py --run and nothing happen(jami interface should open, right??), manual stop at this step. does anyone know how to compile jami to run on ubuntu? or fix this? thanks

Hi, with those details I can’t say what can be wrong, so let’s start from the beginning

What instructions did you follow exactly

(I think ./build.py --init, --dependencies, --install --qt /usr/lib/libqt-jami)

Is there any of these command failing at the end?

This should have generated 2 binaries: jami-project/daemon/bin/jamid & jami-project/client-qt/build-local/jami-qt. Are those binaries present?

If so, instead of --run, you can directly launch jami-qt (with jami-qt -d) for example to see if there is anything wrong (even if --run should show some infos)

i follow the jami-project install manual: ./build.py --init , --dependencies, --install, everything seem to be fine, no error, i also have these file (jami-project/daemon/bin/jamid & jami-project/client-qt/build-local/jami-qt), but when i run using ./build.py --run nothing happen and the manual stop at this point ( go to build from window) i think when ./build.py --run will open normal jami window but nothing happen, thanks

In jami-project, can you run ./install/client-qt/bin/jami-qt -dq and give the output?

installed qt webengine resources not found

please be explicit…

Also what qt-package did you installed?

i think this is my question, how to you install qt6 on ubuntu? i have qt6 6.2.4 dfsg 2ubuntu1

The best solution is to follow what Dependencies — Jami documentation says:

And install the one Jami provides to be sure all modules are there: sudo apt-get install libqt-jami and then build with ./build.py --install --qt /usr/lib/libqt-jami

ubuntu 22 i look on the dependencies page and installed all that still give me that error? the “sudo apt-get install libqt-jami” not found? is this old?

it’s a package in Index of /nightly/ubuntu_22.04 so you need the repo:

sudo apt install gnupg dirmngr ca-certificates curl --no-install-recommends
curl -s https://dl.jami.net/public-key.gpg | sudo tee /usr/share/keyrings/jami-archive-keyring.gpg > /dev/null
sudo sh -c "echo 'deb [signed-by=/usr/share/keyrings/jami-archive-keyring.gpg] https://dl.jami.net/nightly/ubuntu_22.04/ jami main' > /etc/apt/sources.list.d/jami.list"

another solution can be to build Qt yourself

1 Like

i build qt from source, when i run “./build.py --íntall --qt” i still get qt

 Qt6_FOUND to FALSE so package "Qt6" is considered to be NOT
  FOUND.  Reason given by package: qt widget

what version of ubuntu are compatible with jami? what qt library required for jami?

As I said we provide a Qt version built for ubuntu 22.04 (6.3) if you don’t want to build it

what version of ubuntu are compatible with jami?

All of them (until 18.04) for now, we provide packages for those distrib on jami.net

what qt library required for jami?

libqt-jami OR Qt from sources OR the ones in the doc (which as specified, as fairly new, may be unpackaged or incomplete so not recommended).

1 Like

or replace /usr/lib/libqt-jami by your version of Qt.

just a question about interface, i want to move arround the button of jami, what software can i use for edit interface of jami?

any IDE you want (Qt Creator can be the simplest, but devs use various things (vi/emacs/codium will work))

i successfully build the project using libqt-jami for ubuntu
but when i run jami-qt -d, i got “another intance is running” but nothing open/show?? do i miss anything?