Unable to get Jami working on Arch Linux

I’m trying to get Jami working on Arch Linux. It was not clear if a forum post or a gitlab Issue would be more appropriate to get help, so I’m doing both. I will explain the different scenarios I have tried below:

  1. Installed the official jami-daemon & jami-qt packages using pacman. When I run Jami here, it starts up but then I get a Segmentation fault (core dumped) when trying to create an account within the app.

  2. Installed the Arch User Repo (AUR) package called jami-all-bin. When I try to run Jami here, the system tells me I do not have a specific library available. I have looked around and the library provided by Arch is newer than what the pkg is asking for. I then changed that PKGBUILD and tried using different .deb files (Deb 11, Deb 10, Ubuntu 22.04, etc) and they all had different library requirements – this AUR pkg is pulling the binary from the .deb file and then installing it on the system.

If I could better understand what needs to happen, then I believe I may be able to create a source based Arch package that would work. Please help me out as I’d like to try out Jami and not being able to get it working is frustrating. Thanks.

you can get the ful log? (the lines before the segfault) or a backtrace? (also “When I try to run Jami here, the system tells me I do not have a specific library available” what lib?)

Arch is community maintained, so packages are not provided by jami.net

Thank you @sblin for your response. I’m aware that the Arch packages are community maintained and not provided by jami.net, but I was also having trouble building jami from source after making the OP.

First, I’ll address your question about #1 in the OP: Here is the backtrace for the packages maintained by the Arch developers (jami-qt & jami-daemon):

$ gdb jami-qt 
GNU gdb (GDB) 13.1
Copyright (C) 2023 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from jami-qt...

This GDB supports auto-downloading debuginfo from the following URLs:
Enable debuginfod for this session? (y or [n]) 
Debuginfod has been disabled.
To make this setting permanent, add 'set debuginfod enabled off' to .gdbinit.
(No debugging symbols found in jami-qt)
(gdb) run
Starting program: /usr/bin/jami-qt 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffd77ff6c0 (LWP 596413)]
[New Thread 0x7fffd6ffe6c0 (LWP 596414)]
[Detaching after fork from child process 596415]
[New Thread 0x7fffd5bff6c0 (LWP 596416)]
[New Thread 0x7fffd53fe6c0 (LWP 596417)]
[New Thread 0x7fffd4bfd6c0 (LWP 596418)]
[New Thread 0x7fffcd5ff6c0 (LWP 596419)]
[New Thread 0x7fffccbfe6c0 (LWP 596420)]
[New Thread 0x7fffbe9ff6c0 (LWP 596421)]
[New Thread 0x7fffbe1fe6c0 (LWP 596422)]
[New Thread 0x7fffbd1bb6c0 (LWP 596423)]
[New Thread 0x7fffbc9ba6c0 (LWP 596424)]
[New Thread 0x7fff97fff6c0 (LWP 596425)]
[New Thread 0x7fff977fe6c0 (LWP 596426)]
[New Thread 0x7fff96ffd6c0 (LWP 596427)]
"notify server name: mako, vendor: emersion, version: 0.0.0, spec: 1.2"

GL Type: desktop
Surface Type: OpenGL
Surface Profile: CompatibilityProfile
Surface Version: 4.6
QSG RHI Backend: OpenGL
Using Supported QSG Backend: yes
Using Software Dynamic GL: no
Using Multithreaded OpenGL: yes

Init Parameters:
  *  application-name Jami 
  *  browser-subprocess-path /usr/lib/qt6/QtWebEngineProcess 
  *  create-default-gl-context  
  *  disable-features ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture 
  *  disable-setuid-sandbox  
  *  disable-speech-api  
  *  enable-features NetworkServiceInProcess,TracingServiceInProcess 
  *  enable-threaded-compositing  
  *  in-process-gpu  
  *  use-gl desktop 

[New Thread 0x7fff95bff6c0 (LWP 596428)]
[Detaching after fork from child process 596429]
[Detaching after fork from child process 596430]
[Detaching after fork from child process 596431]
[New Thread 0x7fff953fe6c0 (LWP 596434)]
[New Thread 0x7fff94bfd6c0 (LWP 596435)]
[New Thread 0x7fff77fff6c0 (LWP 596436)]
[New Thread 0x7fff777fe6c0 (LWP 596437)]
[New Thread 0x7fff76ffd6c0 (LWP 596439)]
[New Thread 0x7fff767fc6c0 (LWP 596438)]
[New Thread 0x7fff75ffb6c0 (LWP 596440)]
[New Thread 0x7fff74ff96c0 (LWP 596441)]
[New Thread 0x7fff757fa6c0 (LWP 596442)]
[New Thread 0x7fff6ffff6c0 (LWP 596443)]
[New Thread 0x7fff6f7fe6c0 (LWP 596444)]
[New Thread 0x7fff6effd6c0 (LWP 596445)]
[New Thread 0x7fff6e7fc6c0 (LWP 596446)]
[New Thread 0x7fff6dffb6c0 (LWP 596447)]
[Thread 0x7fff6dffb6c0 (LWP 596447) exited]
[New Thread 0x7fff6dffb6c0 (LWP 596448)]
[Thread 0x7fff6dffb6c0 (LWP 596448) exited]
[New Thread 0x7fff6dffb6c0 (LWP 596449)]
[Thread 0x7fff6dffb6c0 (LWP 596449) exited]
[New Thread 0x7fff6dffb6c0 (LWP 596450)]
[New Thread 0x7fff6d7fa6c0 (LWP 596451)]
[New Thread 0x7fff6cff96c0 (LWP 596452)]
"Using locale: en_US"
[New Thread 0x7fff5ffff6c0 (LWP 596466)]
[New Thread 0x7fff5f7fe6c0 (LWP 596467)]
[New Thread 0x7fff5effd6c0 (LWP 596468)]
11:23:16.943         os_core_unix.c !pjlib 2.11 for POSIX initialized
[New Thread 0x7fff5e7fc6c0 (LWP 596469)]
[New Thread 0x7fff5dffb6c0 (LWP 596470)]
[New Thread 0x7fff5d7fa6c0 (LWP 596471)]
Daemon is running
No accounts to migrate
Cannot find dbus interface for screen saver
Can't update current account info data for ""
[Thread 0x7fff5d7fa6c0 (LWP 596471) exited]
[New Thread 0x7fff2bfff6c0 (LWP 596472)]
[New Thread 0x7fff2b7fe6c0 (LWP 596473)]
[Thread 0x7fff2b7fe6c0 (LWP 596473) exited]
[Thread 0x7fff2bfff6c0 (LWP 596472) exited]
Main window loaded using OpenGLRhi
[New Thread 0x7fff2bfff6c0 (LWP 596475)]
[New Thread 0x7fff2b7fe6c0 (LWP 596476)]
[New Thread 0x7fff2affd6c0 (LWP 596477)]
NetworkManager client initialized, version:  1.42.4 , daemon running: yes , networking enabled: yes
primary network connection: 52633498-5ac8-3798-aaa3-5c65aa09a26f default:  yes
[New Thread 0x7fff2a7fc6c0 (LWP 596479)]
[New Thread 0x7fff29ffb6c0 (LWP 596480)]
[New Thread 0x7fff297fa6c0 (LWP 596481)]
[New Thread 0x7fff28ff96c0 (LWP 596483)]
[New Thread 0x7fff13fff6c0 (LWP 596502)]
[New Thread 0x7fff137fe6c0 (LWP 596503)]
[New Thread 0x7fff12ffd6c0 (LWP 596504)]
[New Thread 0x7fff11dff6c0 (LWP 596506)]
[New Thread 0x7fff115fe6c0 (LWP 596507)]
[New Thread 0x7fff10dfd6c0 (LWP 596508)]
[New Thread 0x7ffef93ff6c0 (LWP 596509)]
[New Thread 0x7ffef8bfe6c0 (LWP 596510)]
[Thread 0x7ffef8bfe6c0 (LWP 596510) exited]
[Thread 0x7ffef93ff6c0 (LWP 596509) exited]
[New Thread 0x7ffef93ff6c0 (LWP 596511)]
[New Thread 0x7ffef8bfe6c0 (LWP 596512)]
[New Thread 0x7ffee3fff6c0 (LWP 596513)]
[New Thread 0x7ffee37fe6c0 (LWP 596514)]
[New Thread 0x7ffee2ffd6c0 (LWP 596515)]
[New Thread 0x7ffee27fc6c0 (LWP 596516)]
[New Thread 0x7ffee1ffb6c0 (LWP 596517)]
[New Thread 0x7ffee17fa6c0 (LWP 596518)]
[New Thread 0x7ffee0ff96c0 (LWP 596519)]
[New Thread 0x7ffec3fff6c0 (LWP 596536)]

Thread 38 "jami-qt" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fff5effd6c0 (LWP 596468)]
0x0000000000000000 in ?? ()

Next I will address your question from #2 by uninstalling those packages from #1 and installing AUR package jami-all-bin. This package pulls the jami binary from the following .deb package, https://dl.jami.net/ring-manual/debian_unstable/jami-all_amd64.deb.

Those missing libraries are as follows:

$ ldd /usr/bin/jami | grep found
	libvpx.so.7 => not found
	libre2.so.9 => not found
	libvpx.so.7 => not found

I’m able to find Arch package libvpx which provides a newer library version of libvpx.so.8.
I’m able to find Arch package re2 which provides a newer library version of libre2.so.10.
These two packages were both installed before I started my journey to get Jami to function.

#1 and #2 are two separate issues in the OP as they’re sourcing and installing Jami in different ways.

without debug symbols it will be difficult to answer (“in ?? ()” is not really explicit).

The first theory I’d check is the Qt version (we use 6.2.3 for libqt-jami on dl.jami.net)

Arch Linux has qt6 version 6.4.3 (which can’t be “back-rev’ed”) as seen here Arch Linux - qt6-base 6.4.3-1 (x86_64). The package manager was version 6.2.3 on January 28, 2022.

Reran the backtrace again with auto-downloading debuginfo set to yes, but no change as it’s still showing “in ?? ()” – I hit some forum character limit, so ommitting that result since it had the same outcome.

Any other suggestions?

Another Jami community member helped me fix this by sharing which commits were working for him on Arch on the gitlab Issue I had opened Unable to get Jami working on Arch Linux (#127) · Issues · savoirfairelinux / jami-packaging · GitLab.

For Archers trying to use Jami, the following is still true:

  • Upstream packages (jami-daemon & jami-qt) are still broken & unsure when that will be fixed
  • Upstream package opendht is out-of-date
  • The AUR package jami-all-bin is still broken as the binaries built into all .deb files were built using older libraries which are unavailable on Arch

What does an Archer do? He fixes it :slight_smile: & so I did :tada:

If you want Jami to work today (3/23/2023), then please install the following packages (in order):

  1. opendht-wtf
  2. jami-daemon-wtf
  3. jami-qt-wtf

I will now mark this as the solution.