Connection only sometimes working - usually very bad

Hallo everyone,

first of all: I’d love to use Jami more often, but right now it’s technically simply not possible. When I try to do a videocall, it only works sometimes, to get connected and even when I’m connected, the videocall is in bad quality and drops off real quick. Most of the time I cannot connect at all. For example if a video call dropped of and I try to connect again, it doesn’t work. I really love the approach of Jami, but right now it doesn’t seem to be a good solution for me.
I don’t know if the hard university firewall is the reason or something else. I tried it on Windows PC (Surface Go) and on my Android Phone. Neither of them really worked.
Could you help me?

Greetings, Christoph.

1 Like

Hello Christoph,

Thanks for your question and report.

So, Jami uses a number of different ports for its connections, which your university firewall may be blocking. Please see the What ports does Jami use? entry on the FAQ for more details.

Regarding call quality, it would be helpful if you could check the routing between the two parties of a call, and the version(s) of Jami used on both sides. I believe as of the ‘Free as in Freedom’ major release of Jami last year, official Jami packages distributed via bundle a patched version of ffmpeg that allows for adaptive bitrate and hardware acceleration in calls.

Hope this helps. :slight_smile:

Hello there !
I exactly share christophtill’s view : Jami looks great, major improvements have been made through last updates but still not really technically usable…
Have tried chat messages few months ago : order not often respected.
Video lags a lot, calls sometimes not detected even though app is on on PC and mobile.
Jami still a concept rather than a solution for me too.
It’s kind of frustrating because your communication (twitter or blog) makes it seem like Jami is fully functional.
I would love to participate in a live test a call / group call with someone to test in different conditions !

Christoph and I tried a video session.
Video worked fine but we had troubles with echo on the audio.
I think I have latest version (202011191640)

I also used this version. It seems that there is no echo cancelling integrated.

Hi there,

To my understanding, echo cancellation on the Windows client of Jami is still a work in progress and may not be fully functioning. As such, in the meantime I would recommend folks using the Windows client to wear headphones while using Jami, so as to avoid creating an echo feedback loop.

Regarding the stability of Jami, we naturally do our best to improve it every day, but even in its current form Jami is generally very usable: we use Jami every day for our meetings/messaging, and we have heard numerous success stories from other folks who depend on Jami for communicating. That, of course, is no reason to stop working on Jami, and we continue to further improve it and try to make it work for everyone. :slight_smile:

For the specific issue(s) you are facing, it would be very helpful if you could share logs from the Jami daemon, and ideally steps to reproduce the issue, either on this forum or on the dedicated bug tracker for each project. Please see the Bug report guide for more details.