First timer in the dark

I normally use Signal and I’m experimenting to see if I like Jami.
I have Jami installed as a Snap in Ubuntu.
At my request a friend installed Jami and he chose to do it on an Android tablet.

So far I think I have sent a message to “test” and a couple to my friend. The friend didn’t receive anything and I have not seen any indication of the message being received.

When I try to start either an audio or video call, I get the message:
“Missed outgoing call”.

Does Jami show indications for a sent message being received and subsequently viewed ?
Have I missed a vital step ?
Does Jami display an error when it gets fed up re-trying ?

Just for the hell of it I tried “jami -v” at the command line. It tells me:
~$ jami -v
Testing for explicit PulseAudio choice…
…and PulseAudio has been explicitly chosen, so using it.
Gtk-Message: 00:50:15.511: Failed to load module “xapp-gtk3-module”
Gtk-Message: 00:50:15.649: Failed to load module “canberra-gtk-module”
Gtk-Message: 00:50:15.656: Failed to load module “canberra-gtk-module”
Qt: Session management error: Could not open network socket
Using Qt runtime version: 6.2.3
Jami 202212201555

I already have Jami running and the GUI is not displaying any errors.

Should be ok, there is nothing else to do. What jami version is used the other side?

Hello Sébastien
Thank you for your reply. He installed it on 2023-01-02 from PlayStore and got version 20221225-01

Thankfully things have moved on since I posted that message and we have now video chatted a few times. At first only he was able to initiate calls, each time I tried Jami told me “Missed outgoing call”. Now either of us can initiate a call. I was able to share a screen and he saw it OK, luckily I have two.

We have not yet managed to chat with textual messages, Jami gives the impression that we are sending chat messages but nothing is received at the other end and we see no indication of success or failure.

We both have in excess of 100Mbps download and 20Mbps upload when measured locally, what we get between us I don’t know. He’s in the UK, I’m in Argentina.

Gday @vincewebb Have you linked the phone?
goto account & you’ll see down the bottom, ( Link device)
check this out too,
On phones jami requires configurations in order to work?
this may help.

I have Jami on Linux so it looks like that link is not relevant for me. I only know one other person with Jami and he has it on Android so your link might be helpful for him.

I imagine that friends of Alexander Graham Bell must have taken a while to get phones installed, now I know how he felt.

Your could try removing & install again.
Im using Jami on Zorin os with the snap version installed. & it’s running Great.
or let us know what you have changed to get where your at so-far.

Hi there.

First of all, please don’t give up on Jami. It is excellent, despite some quirks. The Jami development team are, in my experience, excellent, and the product is progressing nicely. Well done to them.

Second, I have first hand experience of running Jami on Kubuntu, Ubuntu, and Android, and second hand experience with Apple, and some of Windows.

With Apple, the users I know of always find that their Jami goes offline. This seems to be a “thing” with Apple, possibly closing the port to save a (miniscule) amount of battery, but the net effect is that Jami becomes dead to the outside world. As far as I know there is no work around.

With Android, I have had excellent results. But, and it’s important, all battery saving must be disabled for Jami. If it isn’t then, again, Jami becomes dead to the outside world, and “missed call” is all you’ll see from it.

With Ubuntu – and this is on a laptop – (20.04lts) I’ve found that Jami does “go to sleep”. I had found a work-around to this, but the most recent update seems to have cancelled out my work-around (see Jami - Linux & Android - Requires Toggling Offline/Online (Disable/Enable) (#1456) · Issues · savoirfairelinux / jami-project · GitLab). “Wakening” Jami seems to require toggling the account enable/disable button. I now need to upgrade the Ubuntu to the newest version to see if the problem goes away.

With Kubuntu (on a desktop, running 24/7, and again 20.04lts), I have had no issues at all. 100% working all the time, and excellent.

The only user I know of with Jami on Windows may not be entirely reliable, so the results are probably not worth considering.

With regard to linking your account across several devices, I have found that unless Jami is running on all those devices pretty much all of the time, there can be some kind of latency regarding synchronisation. I generally don’t link devices, opting to have an account for my desktop, one for my laptop, and one for my tablet. But when I have linked my desktop to my tablet, I have found this works well, and I assume this is due to them both being on 24/7.

Do remember; with Jami, you are the server. There is no intermediate server, à la WhatsApp (yuk!) or whatever. If your machine is off, or simply offline, nothing will flow.

Finally, I have all options in OpenDHT Configuration set to off, and only TURN set to on in the Connectivity settings.

I hope this gives you some pointers. But I stress, don’t give up! Jami will reward you when you have your system set up for it.

Did I mention, don’t give up?!?! :slightly_smiling_face:


Hello @James
I have no intention of giving up but I find myself forced to go slow. So far I have only persuaded one person to install Jami and he doesn’t have as much time, patience or interest in playing around with new software as I do.

I saw from a video that there is a Jami account named “test”, I was hoping that “test” would be a good recipient for test calls but it appears not. My guess is that “test” is not the fully automated, always operational, recipient of test calls that I assumed it would be.

Hi @vincewebb

I think the key thing is to work out what works, tell people how to achieve that, then ask them not to fiddle with any settings - easier said than done, I know! Most of those who I’ve persuaded to use Jami, are using it this way. Once set up, it works fine. I’ve even gone as far as setting things up for people on their systems.

Sometimes getting people to keep their computer on is a hurdle, too, but this would be a requirement for any peer-to-peer comms software, which Signal, et al, isn’t. I’ve generally found that people understand when you tell them that they’re “the server”, and if they switch off, their messages won’t flow - “you are your own server”.

I also think that the desktop environment is probably best. I’m sure Windows is OK for Jami, but Linux is forever and always my first choice. Real independence comes at a cost, and that cost is time setting up and learning.

Just so you know, I created a temporary Jami account, elegantchallenge, to be a “test” account to help you, if you’d like. :slightly_smiling_face:

I will trash it in due course.

Hello James
Thank you for taking the time to help me out. The chat messages you sent me on Jami are the first I have ever received. I sent some back but without knowing if they got through or not it is difficult to communicate. I see the green dot beside “elegantchallenge” so I tried a couple of audio and video calls, sadly I get the usual “Missed outgoing call”.
Thanks again, Vince

Agree wiyh this :wink: can you give us some help our ideas on this :

Hi there. I’ll take a look for you.