Username problem

Hello, I’m so sorry if it’s a newbie question but I searched a lot and didn’t find any answer!
So when I try any username time choose, it doesn’t accept and says username is not valid? What is the problem? What am I doing wrong???

Hello and welcome!

Which Jami client and which version of that client are you using? To my knowledge, the criteria for valid usernames are the following:

  1. the username length is three characters or more, and
  2. the username was not previously registered.

Have you tried typing (but not actually saving) a long random-ish username to see if Jami would still complain? (which it shouldn’t)

Capture_2020_12_08_20_41_16_166
I tried it but didn’t work
Another question in is how to change the language? I couldn’t find any option for that in the setting
(I’m using Windows version)

That is certainly not normal. Myself and another Jami developer just checked and verified that the username registration name server is working properly as of now. So the problem likely isn’t on the server side.

However, we would need more information to help debug this. Please see our bug report guide at https://git.jami.net/savoirfairelinux/ring-project/wikis/tutorials/Bug-report-guide for more details on what’s needed, for example the exact version number. Especially, at the bottom of that page there are instructions on how to launch Jami on Windows in a way that would display logs in a console window that you could copy and send to us. When you launch Jami using those instructions, try typing usernames once again, and there should be texts about it in the logs.

As for changing the language used in Jami, you would do that by changing the system language used throughout your operating system (that’s what Jami uses to decide which language to display).

I have the same problem. I cannot recover a newly created account. the documents say their is only 2 options one transfer using the link button and the second is to proceed to a specfici directory which doesnt work as the directory does not exist. the document does say depneding on if phone, android is rooted. This is the latest version as of Dec-9-2020

It’s not the same problem https://git.jami.net/savoirfairelinux/ring-project/wikis/tutorials/Frequently-Asked-Questions#account-5

@ariya if possible get the logs, but is ns.jami.net blocked at some point? Logs will say the error, but it’s working there.

I am having the exact problem Whatever I type in the username, it turns red and will not accept it. I tried just typing in a long string of random letters and numbers and the same thing. I’d really like to try out this product but, so far the experience is zero.

I just tried entering my email address and it accepted it but, I got a name registration error saying the user name could only contain 3 to 32 characters of letters, numbers and, underscores. It also implies the user name is good but, only exists on this devices. This is very confusing. Do I now have an account created or not. If so, how do I test it to be sure it is working?

You have to check the username length, never use a capital letter in the username and also check the user name you have entered is not previously registered.